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Chapter 1: Introduction

About the Music Library
The Music Library is a series of databases designed to help music
directors, educators and performers of all kinds organize information
about music and musicians. The Music Library lets you catalogue your
music, track performances, create program notes, catalogue composers,
record student grades and attendance, and keep up with equipment and
music loans.

Music Library Modules
Your Music Library CD contains all of the following software modules.
A single license allows you to install one library module, its member
database, and a gradebook or the attendance module.

• TBML: The Band Music Library

• TChML: The Choral Music Library

• TCML: The Church Music Library

• TOML: The Organist Music Library

• TOrML: The Orchestra Music Library

• TPML: The Performer Music Library

• TRML: The Recording Music Library

• TROML: The Organ Recording Music Library

• TSML: The Singer’s Music Library

• Gradebook6: 6-week grade book

• Gradebook9: 9-week grade book

• Gradebook13: 13-week grade book

• Attendance: Attendance record

• BandMember: Band membership database
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• ChoralMember: Choral membership database

• OrchestraMember: Orchestra membership database

Sample Files
The Music Library CD includes sample databases for band, choral and
orchestra music. They are labeled as follows:

• BandSamp.fp3

• ChorSamp.fp3

• OrchSamp.fp3
These lists were donated by Iowa, Michigan and Arizona music
educators. You can import them directly into the related databases using
the Import command (see Chapter 1, Importing and Exporting Data).

New Features in version 5.0

• Gradebook module lets you set grading criteria, track students,
record grades and print grade reports in 6-, 9- or 13-week periods

• Attendance module lets you track student attendance

• Scheduler lets you create a monthly report of coming events

• Program record keeps track of performances and lets you create
a group biography

• Midi file option lets you add music clips to your database and play
them from within The Music Library

• Expanded Instrumentation Details function in the Band Music
Library now includes mariachi, percussion, steel drum and
orchestra

• Loan Details windows lets you search loaned materials by title,
borrower or due date, and includes contact information for easy
retrieval
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• Libraries offer more customization options for added flexibility,
including five preset list views, five customizable list views, and
more nameable fields

• Revised library layout puts all major fields in the main window for
easier access

• Auto-sort icons offer instant sorting of list views

• Members section now accommodates up to 20 fundraisers

• Instrument, concert attire and uniform inventories now appear in
separate windows

About this guide

This manual is a comprehensive guide to all of the Music library modules.
The guide is organized into the following chapters:

• Chapter 1: Introduction
This chapter describes The Music Library software and how to
use this guide.

• Chapter 2: Installation
This chapter explains your minimum system requirements and
provides installation instructions for Macintosh and Windows
operating systems.

• Chapter 3: Music Library Basics
This chapter describes features that are common to all Music
Library modules, providing instructions for basic database
operations and management.

• Chapter 4: The Library Modules
This chapter describes the nine different music libraries and how
to use them.

• Chapter 5: The Gradebook Modules
This chapter describes the gradebook module and how to use it.
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• Chapter 6: The Attendance Module
This chapter describes the stand-alone attendance module and
how to use it.

• Chapter 7: The Member Modules
This chapter describes the member modules and how to use
them.

• Chapter 8: Troubleshooting
This chapter explains problems you may have and how to fix
them.

 This manual also offers critical information, notes and tips. These are
marked as follows:

• IMPORTANT: This information is critical to understanding and
using The Music Library software. Please read all sections
marked as important.

• NOTE: This is extra information that will help you understand
and use the software. Notes also indicate exceptions to the
instructions. For example, if one of the library modules does not
contain a button listed in the library instructions, it will be
mentioned in a note.

• TIP: This is a suggestion about how to use your software for
optimum performance. You do not need to follow the tips listed in
this manual, but they may offer you insights into how to use the
Music Library to make your job faster, easier or more flexible.

Macintosh/PC Conventions
Some of the menus and commands are different in the Macintosh and
Windows versions of the Music Library. This occurs because the
programs were created on different versions of FileMaker software, in
order to prevent Macintosh users from having to upgrade to System 8.5.
Whenever there are differences between the Macintosh and Windows
instructions, the Windows instructions will appear first, followed by
Macintosh instructions in parentheses.
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Example: “Open the Records (Mode) menu…”

In this example, Windows users should open the Records menu and
Macintosh users should open the Mode menu.
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Chapter 2: Installation

MacOS Installation

Minimum Hardware/Software Requirements:

• 68020 or higher processor, or any Power Macintosh model

• System 7.1 or higher

• 8 MB of available memory (RAM) when virtual memory is on, or
16 MB when virtual memory is off

• A hard drive

• A CD-ROM drive

To install The Music Library for the first time:

NOTE: You must use the installation program to install Music Library
modules. You can’t install the Music Library by dragging files to your
hard drive.

1. Save your work and exit all other open programs.
2. Insert the Music Library CD into your CD-ROM drive.
3. Double-click on the CD icon.
4. Double-click on the MacInstaller folder.
5. If you want to install a password-protected version of the Music

Library, double-click on the Password folder. If you do not want
to use a password, double-click on the NoPassword folder. You
can install some modules with password protection and some
without. Simply install the programs from the appropriate folders.

6. Double-click on the program you want to install (see Chapter 1,
Music Library Modules).

7. The installer welcome window will appear. Click on Continue.
8. Read the license agreement and click on Agree to continue with

the installation.
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9. Select a location for the new folder and click on Install. The
software will be installed in the desired location.

To update an earlier version of The Music Library:

1. Following the instructions above, install The Music Library
version 5 software in a different location from your old Music
Library software.

2. You can import your old data into the new database. First, open
up the new, empty database file.

3. Open the File menu and select Import/Export then select Import
Records.

4. Find and select your old database, then click on Open.
5. A new dialog box will appear. In the View By field select

Matching Names.
6. Click on Import.

Windows Installation

Minimum Hardware/Software Requirements

• In Intel compatible 486/33 PC or higher

• Windows 95, Windows NT 4.0 or later operating system

• 8 MB available memory (RAM)

• A hard drive

• A CD-ROM drive

To install The Music Library for the first time:

NOTE: You must use the installation program to install Music Library
modules. You can’t install the Music Library by dragging files to your
hard drive.

1. Save your work and exit all other open programs.
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2. Insert the Music Library CD in your CD-ROM drive.
3. Click on the Windows Start button and select Run.
4. Click on Browse and find your CD drive, which will be labeled

“PCInstallers.”
5. Double-click on the PCInstallers CD.
6. Double-click on the PCInstallers folder.
7. If you want to install a password-protected version of the Music

Library, double-click on the Password folder. If you do not want
to use a password, double-click on the NoPassword folder. You
can install some modules with password protection and some
without. Simply install the programs from the appropriate folder.

8. Double-click on the folder for the program you wish to install
(see Chapter 1, Music Library Modules).

9. Double-click on the Setup icon.
10. Click on OK in the Run dialog box.
11. The installer welcome window will appear. Read the instructions

and click on Next to continue.
12. Read the license agreement and click on Yes to continue.
13. Select the location where you wish to install the software, then

click on Next.
14. A verification window will appear. Click on Next to install the

software in the desired location.
15. To install additional modules, simply repeat these instructions.

To update an earlier version of The Music Library:

1. Following the instructions above, install The Music Library
version 5 software in a different location from your old Music
Library software.

2. You can import your old data into the new database. First, open
up the new, empty database file.
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3. Open the File menu and select Import Records.
4. Find and select your old database, then click on Open.
5. A new dialog box will appear. In the View By field select

Matching Names.
6. Click on Import.

 
 
 Technical Support
 Riden Consulting, Inc.
 621 E. Geneva Drive
 Tempe, AZ 85282-3734
 
 Phone: 480.968.0407
 Message: 480.966.0107
 Fax: 480.929.0248
 E-mail: riden@riden.com
 Web: http://www.riden.com
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 Chapter 3: Music Library Basics
 

 All of the Music Library modules are database programs. There are
many functions that are common to all of the databases. These are
described in this chapter. For information about module-specific functions,
see the chapter pertaining to that module.

 

 Licensing
 When you first open any of the Music Library modules, a licensing screen
will appear asking for your name and license number.

 If you have purchased The Music Library, you should have a welcome
letter that lists your user name and license number. Complete the
following steps:

1. Type in your user name and press the ENTER key on your
number pad.*

2. Type in your license number and press the ENTER key on your
number pad.*

3. Click on OK.

* If you are using a laptop computer or a keyboard that does not have a
number pad, hold the FN key and press ENTER (RETURN).

If you have not received your license number, you purchased the program
from another source, or you downloaded the program from the Internet,
you may operate the software for 30 days without a license. After 30
days you must enter a license number or the program will terminate. To
operate the Music Library without a license number, complete the
following steps:

1. Place your cursor in the user name field and then press the
ENTER key on your number pad.*

2. The cursor will move to the license number field. Press the
ENTER key on your number pad.*



11

3. Click on OK.

* If you are using a laptop computer or a keyboard that does not have a
number pad, hold the FN key and press ENTER (RETURN).

IMPORTANT: If you click on OK without pressing ENTER from the
two fields, your Music Library software will not operate correctly. You
must enter the blank fields correctly to use the 30-day trial option.

Managing Your Passwords
You may password-protect any or all of your Music Library modules.
When you choose the password protection option, you must enter a
password in order to access the software.

To select the password protection option for a particular software
module, install that module from the Password folder on your installation
CD (see Chapter 2).

To select the unprotected option for a particular software module, install
that module from the “NoPassword” folder on your installation CD (see
Chapter 2).

If you have already installed one version of the software and wish to
change to the other version, you must reinstall the program from the
appropriate folder. If you have already entered data into the program, you
can export it from the old database and import it into the new one. (See
Importing and Exporting Data  later in this chapter.)

The default passwords for the Music Library modules are listed on the
welcome letter you received with your software. If you do not have this
letter, contact technical support at:

Phone: 480.968.0407
Fax: 480.929-0248
E-mail: riden@riden.com
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IMPORTANT: RCI Software recommends that you keep your
passwords private. In particular, we recommend that you never share
passwords with students.

To change your passwords:

If you wish to change the password on a particular module, you must
change the password for each RCI file  associated with that module.
These files are listed under the Window menu. If you do not change the
password for each of these files, the Music Library will require a
password for every file each time you open the software.

1. Open the module you wish to change.
2. Open the File menu and select Change Password.
3. Type in the original password in the Old password field.
4. Type in the password you want to use in the New password

field.
5. Retype your new password in the Confirm New Password field.
6. Click on OK.
7. Open the Window menu and select one of the other windows.
8. Repeat steps 2-6 above.
9. Repeat this process for every file listed in the Window menu, or

just for those files you wish to change (the rest will remain on the
original password).

TIP: You can create different passwords for different windows within a
single program. For example, you may want to allow other users to
modify church library data, but not have access to the member window.
You can give out the password for the main data files, and create a
different, private password for member information.

Working with Database Files
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The Music Library is made up of several database files. A database is a
powerful tool for storing, organizing, searching and displaying large
amounts of information. For example, the Band Music Library database
lets you store information about your band music collection. The Band
Member database lets you record data about band members such as
grade level, instrument, and contact information.

To open a database file:

Double-click on the main program icon or Windows shortcut.

The icon will look like this  (MacOS) or this  (Windows)

To exit a database file:

Open the File menu and select Exit (Quit).

To save database files:

The Music Library automatically saves changes to your databases as
you work, so there is no Save command. When you exit a database,
the most recent information is saved automatically.

To make a copy of a database file:

1. Open the File menu and select Save a Copy As.
2. Enter a name for your file.
3. Select the location where you want to save the file.
4. Select a file type. In general, you will save a “copy of current

file.” If you have limited amounts of memory, you can save to a
compressed copy. The file will need to decompress before
running. Saving a clone will save a blank copy of the database,
without any of your data or customized fields.

5. Click on Save.
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Working with Records
Each database is made up of a group of individual records. Each record
contains information about one person or piece of music. Every record
receives a unique number. The current record number and the total
number of records in the database are displayed at the top of the
database window.

The information in a record is entered into fields. For example, the Last
Name field might contain a band member’s last name.

The Music Library allows you to create, delete, duplicate, browse, search,
omit and sort records. You can search and sort records by any field.
Sorting by Last Name, for example, would alphabetize the records by
member’s last name. Sorting by Grade/Class would arrange the records
in order of members’ grade levels.

You can search for records using any field, also. For example, you can
search for a particular student by name, or you can search for all
members in the 10th grade.

When you search for records, The Music Library will display only the
found set. Most of the commands you use will apply only to that found
set. Use the Show All Records (Find All) command described below to
work with all records in the database.

To create a new record:

1. Open the Records (Mode) menu and select New Record, or click
on the New Record button at the bottom of most module
windows.

2. Place your cursor in a data field and begin typing. There is no
need to save each new record—the Music Library automatically
saves your data.
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For more information on entering data, see Working with Fields later in
this chapter.

To duplicate an existing record:

Open the Records (Mode) menu and select Duplicate Record. A
duplicate record will be added to the end of the database. You may
edit the two records separately. Changes made on a record after
duplication will not appear on its copy.

To delete an existing record:

1. Open the Records (Mode) menu and select Delete Record.
2. A verification window will pop up. Click on Delete to confirm.

The record will be removed from the database.

To delete all records being browsed:

1. Open the Records (Mode) menu and select Delete All.
2. A verification window will pop up. Click on Delete to confirm.

IMPORTANT: This command will delete all of the records in the found
set. If you are browsing all records, it will delete your entire database.
You cannot recover these records once they are deleted!

To view all records:

1. Open the Records (Select) menu and select Show All Records
(Find All). This displays all the records in the database.

2. Use the navigation buttons at the bottom of the window to scroll
through the records.

 takes you to the first record in the set.
 takes you to the next record (by record number)

 takes you to the previous record (by record number)



16

 takes you to the last record in the set

 lets you select a record by its number

NOTE: The Gradebook and Attendance modules do not offer these
buttons because records are displayed in a list view.

To search records:

1. Open the View (Mode) menu and select Find Mode (Find). In
the library modules, you may also click on the Find button at the
bottom of the screen.

2. Type your search criteria in the appropriate field. For example, to
search for music by composer Joe Smith, type “Joe Smith” in the
Composer field.

3. In Windows, press the ENTER key. On a Macintosh, open the
Mode menu and select Find again. (or click on the Find button in
the library modules).

After the find is performed, only the records in the found set will be
available to use. If you want to go back to the full

Advanced searching techniques:

To find: Type this: Example:

A range of words in a
text field

Start and end points
separated by an ellipsis
(…)

“Bill…John” finds Bill,
Chris and John

Words that start with
specific characters

The specific field
characters

“Chris Smith” finds Chris
Smith, Chris Smithson
and Christopher
Smithwick

An exact word in a text
field

An equal sign (=) before
the word

“=John” finds John and
John Smith but not
Johnson
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Only an exact word in a
text field

Two equal signs (==)
before the word

“==John” finds John and
John Smith but not
Johnson

Exact matches for words
in several fields

An equal sign (=) before
each word

“=John” in the First
Name field and “=Smith”
in the Last Name field
finds John Smith

Exact matches on several
words in the same text
field

An equal sign (=) before
each word

“=Chris =Smith” finds
Chris Smith and Smith
Chris

Words that vary by zero
or more characters in a
text field

One wildcard character
(@) for each unknown
character

“Gr@y” finds Gry, Gray
and Grey

Words that vary by more
than one character in a
text field

The wildcard character
(*) for all unknown
characters

“Ste*en” finds Stephen,
Steven and Stebben

Records that show either
one word or another

Type the first search
criteria, then open the
Request menu, select
Add New Request and
type in the second
criteria

Typing “Back” in the
composer field, then
typing “Mozart” in the
same field finds all
pieces by Back or
Mozart

4. database, open the Select (Mode) menu and select Show All
Records (Find All), or click on the Find All button.

NOTE: Searches are not case-sensitive.

To omit records from the current list:

1. Find the record you wish to omit from the found set.
2. Open the Records (Select) menu and select Omit Record (Omit).

In the library modules, you may also click on the Omit button at
the bottom of the screen.
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The record will be removed from the found set, but not from the
database. To display all records, simply open the Records
(Select) menu and select Show All Records (Find All).

To omit a string of consecutive records:

1. Go to the first record that you want to omit.
2. Open the Records (Select) menu and select Omit Multiple.
3. Enter the number of records you want to omit, starting with the

current record.
4. Click on Omit.

To view omitted records:

After you have omitted one or more records from the current list, you
can view just the omitted records by opening the Records (Select)
menu and selecting Show Omitted (Find Omitted). Only the omitted
records will be displayed. To display all records, open the Records
(Select) menu and select Show All Records (Find All).

TIP: The omit function can work as a “select” function to display a
group of records that may not show up together in a single search.
Simply omit all the records that you want in your group, then use the
Show Omitted function to display your selection.

To sort records:

1. Open the Records (Mode) menu and select Sort. The Sort dialog
box will appear.
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2. In the box on the left, select a field to sort by. (example: selecting
Title will sort records alphabetically by title.)

3. Click on Move to enter your field in the sort order box on the
right.

4. With the field selected, choose a sort order at the bottom of the
dialog box. “Ascending Order” sorts numbered fields in
ascending numerical order and text fields in alphabetical order
(A-Z). “Descending Order” sorts numbered fields in reverse
numerical order and text fields in reverse alphabetical order (Z-
A).

5. If you want to use multiple sort criteria repeat steps 2-4 for all
fields you wish to use. To remove a field simply select it in the
Sort Order box and click on Clear.

6. Click on Sort. The Music Library will sort your records. To exit
without sorting, click on Done.

NOTE: Doing a Show All Records (Find All) command will undo your
sort. Records will return to the order in which they were entered.

Working with Fields
Fields are the basic units of data in a database file. Fields store, calculate
and display the data you have entered. There are several types of fields
in the Music Library:

• Text fields let you type in any text you wish. Position your cursor
in the field and begin typing.

• Pull-down menu fields let you select one of several pre-defined
options. You can also edit these lists (see instructions below) or
override the menu by placing your cursor in the field and typing
your own text.

• Radio buttons let you select one and only one pre-defined option.
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• Check-boxes let you select as many pre-defined options as you
wish.

• Calculation fields make automatic calculations based on data you
have entered in other fields. For example, in the member
databases, you can enter each member’s fundraiser earnings and
see an automatic tally of your total group earnings.

• Graphics and audio fields let you insert pictures or sound files.

To edit a pull-down menu field:

1. Select the field to display the menu and select Edit...
2. The Edit Value List dialog box will appear. You can edit or delete

existing values, or enter new values. Each value must appear on
a separate line. You can insert your value at the top, bottom, or
anywhere in the middle of an existing list. Enter a carriage return
(ENTER key) to insert a new line.

3. Click on OK. The new item will appear in the menu on all
records.

TIP: Add items to a pull-down menu when you plan to use them in more
than one record. If you are only using a value in one record, you should
type the text into the field instead of adding it to the list.

To format text in fields:

You can specify the font, size, style, alignment, spacing and color of text
in your fields. Your formatting changes will apply only to the current
record, not to all records in the database.

1. Select the text you wish to format.
2. Open the Format menu and select Text.
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3. Select the desired formatting options in the Text Format dialog
box.

4. Click on OK.

Nameable Fields
RCI Software has tried to include fields for all of the information that you
might want to record. However, we recognize that every music program
is different, with different database needs. Therefore, the Music Library
offers several nameable fields that you can customize to meet your
needs. Any field name surrounded by a box is editable, whether or not it
has a title in it already. In the main library windows, these fields are
labeled “Nameable.”

NOTE: Your edited names will not appear in the field list when you do a
sort. Nameable fields show up in the sort box as “renamed1,”
“renamed2,” etc.

To edit a nameable field:

1. Select and delete the current field name, if one exists.
2. Place your cursor in the field name box and enter the desired

name.

NOTE: It is inadvisable to create a name that is being used for another
field. If you need to repeat a name, use numbers to differentiate them
(example: Title 1, Title 2, etc.).

Printing Records
The Music Library lets you print records, lists, and a variety of reports
and labels. Whenever you print data from your databases, you must
select printing options within the Print dialog box. Select your print options
as follows:

• Copies: Select the number of copies to print.

• Print Range (Pages): Select All, or a range of pages to print.
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• Paper Source: Select the paper tray.

• Printer: Select the appropriate printer.

• Destination: Select Printer or File (in general, select Printer).

• Print: To print all records in your found set, select Records
Being Browsed. To print only the record currently being
displayed, select Current Record. To print a record with no data,
select Blank Record.

Importing and Exporting Data
You may already have a music database in another program such as
Microsoft Excel or ACCESS. You can import this data into the Music
Library. You can also export your Music Library data for use in other
programs.

To import data from ACCESS:

1. Open the ACCESS database.
2. Open the File menu and select Save as/Export.
3. In the Save as Type field, save to an external file or database.
4. Click on OK.
5. Click on Export.
6. Save the data as a tab- or comma-separated text file.
7. Open the Music Library database into which you wish to import

the data.
8. Open the File menu and select Import Records (On a Macintosh,

select Import/Export first).
9. Locate the exported data and click on Open.

To import data from Excel:

1. Open the Excel database.
2. Open the File menu and select Save As.
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3. Save to external file or database.
4. Click on OK.
5. Export the file using file extension SLK. Although any of the file

formats listed below will work, the SLK extension is
recommended.

6. Open the Music Library database into which you wish to import
the data.

7. Open the File menu and select Import Records (On a Macintosh,
select Import/Export first).

8. Locate the exported data and click on Open.

To import data from other programs:

1. Open the program.
2. Open the File menu and select Save As.
3. Save to an external file and click OK.
4. Export the file using any of the file extensions listed below. The

SLK extension is recommended if it is available. If you have
difficulty exporting files from another program, please refer to the
documentation that came with that program.

5. Open the Music Library database into which you wish to import
the data.

6. Open the File menu and select Import Records (On a Macintosh,
select Import/Export first).

7. Locate the exported data and click on Open.

Accepted file formats:

• FileMaker Runtime files (*.RCI, *.FM)

• FileMaker files (*.FP3, *.FP5, *.FM)

• Tab-separated text (*.TAB, *.TXT)
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• Comma-separated text (*.CSV, *.TXT)

• SYLK (*.SLK)

• DIF (*.DIF)

• WKS (*.WK1, *.WKS)

• BASIC (*.BAS)

• MERGE (*.MER)

• ClarisWorks (*.CWK, *.CWS)

To export data from a Music Library database:

1. Open the database from which you want to export data.
2. Open the File menu and select Export Records (On a Macintosh,

select Import/Export first).
3. Type in a name for the exported file.
4. Choose a location in which to save the file.
5. Choose a file type from the menu at the bottom of the Export

dialog box.
6. Click on Save.


